1. Forum używa plików Cookies. Dowiedz się więcej o celu ich używania i możliwości zmiany ustawień Cookies w przeglądarce. Czytaj więcej...

ROZWIĄZANE Błąd 500 przy próbie aktualizacji prestashop modułem 1 click upgrade

Dyskusja w 'Sklep internetowy' rozpoczęta przez użytkownika janNowak, 27 Czerwiec 2018.

  1. janNowak

    janNowak Początkujący

    Wiadomości:
    9
    Docenione treści:
    0
    Dzień dobry. Przy próbie aktualizacji Prestashopa(1.6.1.18 do 1.6.1.19 modułem 1 click upgrade) pojawia się error 500.
    Podczas skanowania plików presty modułem Antyvirus pro, oficjalny moduł z repozytoriu presty pojawia się błąd 504.
    Skanowanie witryny zakupionym modułem czy możliwość aktualizacji oprogramowania do nowszej wersji to przecież podstawy. Z tym nie powinno byc nigdy najmniejszego problemu. To czynności standardowe i podstawowe coś jak wrzucenie pliku na serwer. Próbuję juz 10 dzień. POMOCY!
     
  2. yakusa

    yakusa Stały bywalec

    Wiadomości:
    37
    Docenione treści:
    2
    Witam serdecznie. Wersja .19 nic nie wnosi poza dodaniem hooka dla oficjalnego modułu odpowiedzialnego za RODO/GDPR. Zatem jeśli Pan z niego nie korzysta to aktualizacja nie jest konieczna. W razie pytań i wsparcia dla PrestaShop zapraszam na www.facebook.com/prestashark.eu
     
  3. janNowak

    janNowak Początkujący

    Wiadomości:
    9
    Docenione treści:
    0
    Tak tak. a co będzie jeśli pojawi się następna aktualizacja? po za tym pozostaje kwestia 504 braku możliwości przeskanowania presty modułem... ale nie kierujmy problemy na boczny tor. Tematem nie jest co programiści presty w prescie 19. Poza tym proszę wybaczyć ale jeśli chcę wykonać tą aktualizację to jest to mój wybór i moje prawo mam wykupioną usługę hostingową. Dziekuję
    p.s. korzystam , kupiłem moduł odpowiedzialny za RODO/GDPR
     
  4. yakusa

    yakusa Stały bywalec

    Wiadomości:
    37
    Docenione treści:
    2
    Prosze zatem powiedzieć kiedy zaobserwowano pojawienie się błędu 504? Po zainstalowaniu jakiegoś konkretnego modułu? Po aktualizacji?
    Czy logi php/apache coś mówią?
    Jaką posiada Pan wersję PHP?
     
  5. janNowak

    janNowak Początkujący

    Wiadomości:
    9
    Docenione treści:
    0
    Wersja Php 7.1(na 5.6 tez errory 500,504) modul mazywa się Antyvirus Pro. To nie kwestja tego modulu poniewaz na hostingu webd.pl skanuje jak należy i na webd podnioslem preste do 1.61..19 bez problemu. 504 pojawia sie gdy uruchamiam jedna z funkcji tej wtyczji a mianowicie skanowanie. Po kilkudziesięciu sekundach. Czas wykonania skryptu.

    Witryna dziala.
    Problem to:
    1 nie mogę na home.pl zaktualizowac presty(error 500) niezaleznie od modulu Antyvirus pro. Kiedys przy poprzedniej aktualizachi presty tez mialem error 500 ale w koncu sie udalo. Tym razem juz 10 dzien lipa.
    2. Nie mogę do konca przeprowadzic wtyczka skanowania(error504)
    Mam czekać na podniesienie parametru czasu wykonania skryptu. Probowalem php.ini ale to uslugodawca podnosi, wiec czekam zgodnie z zapowiedzią. Mam nadzieje ze nie bedzie takich perturbacji wiecej. Mordęga.
     
    Ostatnia modyfikacja: 27 Czerwiec 2018
  6. yakusa

    yakusa Stały bywalec

    Wiadomości:
    37
    Docenione treści:
    2
    Poproszę o link do modułu. Nigdzie go nie znajduje po nazwie Antyvirus Pro :/
     
  7. janNowak

    janNowak Początkujący

    Wiadomości:
    9
    Docenione treści:
    0
  8. yakusa

    yakusa Stały bywalec

    Wiadomości:
    37
    Docenione treści:
    2
    Tak to widziałem. Ale nie wydam ponad 400zł na ten moduł, żeby sprawdzić jego działanie na moim serwerze w home...
    Jeśli chodzi o home to trzeba mieć również na uwadze konfigurację przekierowania domeny (z separacją serwisu, lub bez) - w przypadku PrestaShop czasami pomaga opcja "przekierowania na podkatalog bez separacji serwisu".
    Czy logi php/apache były sprawdzone? Coś ciekawego w nich się znajduje co mogłoby naprowadzić na ew. źródło problemu?

    Ogólnie zwiększenie parametru max_execution_time powinno pomóc, choć cudu bym się w przypadku "domku" nie spodziewał... Jaką wartość ma ten parametr na webd?
     
    Ostatnia modyfikacja: 28 Czerwiec 2018
  9. LukaszC

    LukaszC eCommerce Team home.pl Moderator forum

    Wiadomości:
    600
    Docenione treści:
    65
  10. janNowak

    janNowak Początkujący

    Wiadomości:
    9
    Docenione treści:
    0
    Jak włączam z separacją to banery mi znikają. ale sprawdzę mimo to czy pójdzie skanowanie.

    problem z error 500 przy upgradzie zażegnany, podniesiono czas wykonania skryptu(dzieki), dzisiaj jeszcze raz muszę zrobic upgrade bo rano pojawiła sie kolejna wersja presty.


    Niestety po włączeniu przekierowania z separacją przy próbie skanowania mudułem po kilkudziesięciu sekundach error 500. Wracam do poprzedniego przekierowania.
     
    Ostatnia modyfikacja: 28 Czerwiec 2018
  11. LukaszC

    LukaszC eCommerce Team home.pl Moderator forum

    Wiadomości:
    600
    Docenione treści:
    65
    @janNowak błąd 500 jest dosyć specyficzny, ponieważ niewiele mówi, sugeruję skontaktować się z naszą infolinią lub poprzez formularz kontaktowy w celu zweryfikowania logów serwera podczas wykonywania skanowania. Administratorzy będą mogli sprawdzić dokładnie, czy nie przekraczasz jakiś parametrów bezpieczeństwa.
     
  12. janNowak

    janNowak Początkujący

    Wiadomości:
    9
    Docenione treści:
    0
    Prawdopodobnie przekraczam, ale przeskanować zakupionym modułem chcę bo taka jego funkcja, po to kupiłem. Skontaktuję się z infolinią.
    Dzięki za pomoc.
    Pozdrawiam
     
  13. PaulinaZ

    PaulinaZ eCommerce Team home.pl Moderator forum

    Wiadomości:
    9
    Docenione treści:
    0
    @janNowak rozumiem, że temat nie dotyczy usługi Clickshop? Czy udało się skontaktować z infolinią?
     

Poleć forum znajomym