1. Forum używa plików Cookies. Dowiedz się więcej o celu ich używania i możliwości zmiany ustawień Cookies w przeglądarce. Czytaj więcej...

ROZWIĄZANE Cache strony a szablon

Dyskusja w 'Hosting i domeny internetowe' rozpoczęta przez użytkownika X9DESIGN, 21 Marzec 2017.

  1. X9DESIGN

    X9DESIGN Bystrzak

    Wiadomości:
    63
    Docenione treści:
    4
    Kłaniam się.

    Mam pytanie. Otóż posiadam na swoim serwerze Business Cloud Server zainstalowanego Wordpressa za pomocą autoinstalatora. I właśnie w tym momencie odkryłem dziwne zjawisko. Mianowicie kiedy usuwam pliki szablonu z serwera, nawet via SSH, to w samej przeglądarce one wciąż się wyświetlają. To znaczy, fizycznie ich na serwerze nie ma, ale kiedy odświeżam w przeglądarce bezpośredni link do usuniętego fizycznie pliku, to przeglądarka wciąż wyświetla tego pliku zawartość. Sam Wordpress nie posiada żadnej wtyczki, która mogłaby przechowywać we własnej pamięci podręcznej plików. Nic z tych rzeczy. Jak to się dzieje? Czy z tym związek fakt, że akurat o tej godzinie wykonuje się backup serwera? Potrzebuję zmienić zawartość pliku, a w żaden sposób nie mogę tego zrobić. Bo przeglądarka wyświetla mi wciąż początkową jego zawartość. Nawet jeśli go usunę fizycznie z FTP/SSH. :)

    Z góry dziękuję za pomoc.
     
  2. Adam

    Adam Social Media home.pl home.pl Administrator forum

    Wiadomości:
    262
    Docenione treści:
    73
    Przeglądarka także posiada pamięć podręczną, w której zapisuje dane witryny :) Podaj może w wiadomości prywatnej adres, który wywołujesz - sprawdzimy to.

    Druga opcja jest taka, że kasujesz być może katalog A, a domena odwołuje się do katalogu B. Wiem, głupie ale miałem kilka razy tego typu sytuację (klient miał dwa foldery o podobnej nazwie z jedną różnicą).
     
  3. X9DESIGN

    X9DESIGN Bystrzak

    Wiadomości:
    63
    Docenione treści:
    4
    OK Już wiem co jest grane. Moja wina. Głupie to.

    Zapomniałem, że kopiowałem instalację do innego katalogu nie usuwając plików w jej pierwotnej lokalizacji. Stąd byłem pewien, że grzebie w dobrym katalogu.

    Przepraszam za zrobienie niepotrzebnego szumu.
     
  4. Adam

    Adam Social Media home.pl home.pl Administrator forum

    Wiadomości:
    262
    Docenione treści:
    73
    @X9DESIGN Na moje oko zrobiłeś zmianę w pliku, który leży w innym katalogu :) Sprawdź dokładnie na jaki katalog kieruje subdomena es.xnine.eu. Przed chwilą zmieniłem nazwę pliku i pojawiło się 404 :>
     

Poleć forum znajomym