1. Forum używa plików Cookies. Dowiedz się więcej o celu ich używania i możliwości zmiany ustawień Cookies w przeglądarce. Czytaj więcej...

Prośba o pomoc Certyfikat SSL Wordpress instaluje się tylko na stronie głównej

Dyskusja w 'Certyfikaty SSL' rozpoczęta przez użytkownika Luinehil, 26 Czerwiec 2018.

  1. Luinehil

    Luinehil Nowy użytkownik

    Wiadomości:
    2
    Docenione treści:
    0
    Witam,

    bardzo proszę o pomoc w instalacji certyfikatu SSL.
    Zakupiłam certyfikat, poprawnie przypisałam go do domeny, ale nie mogę go zainstalować na Wordpresie.

    Obecnie domena http://atopestka.pl jest pusta, z zainstalowanym jednym motywem. Próbuję zainstalować certyfikat SSL, korzystając z tego rozwiązania: https://pomoc.home.pl/baza-wiedzy/j...ej-strony-www-certyfikat-zostal-zainstalowany

    Problem jest, że zarówno za pomocą wtyczki jak i wklejeniu kodu w htaccess wygląda to tak, że ssl działa tylko na stronie głównej, a na podstronach już nie (i 301 redirect przekierowuje na stronę główną, nie pozwalając na wczytanie się podstron).

    Robiłam różne rozwiązania, ale nadal nic nie działa. Próbowałam obejść to innymi wtyczkami (SSL content fixer) i działało, ale po jakimś czasie wyskakuje ERROR 500. Do tego dochodzi problem bardzo wolnego ładowania się strony na samym początku - nawet 10 sekund!!! Przypominam, strona jest kompletnie pusta...

    Przeszukując rozwiązanie w Internecie znalazłam coś takiego:

    "I had exactly the same problem and the solution for me was to add these lines to /etc/apache2/sites-enabled/default-ssl.conf, which is my SSL-enabled website's configuration file:
    <Directory /var/www/html/>
    AllowOverride All
    </Directory>
    Of course, this assumes DocumentRoot /var/www/html.
    The thing is that Wordpress uses .htaccess rules to process the URLs and for them to work, AllowOverride All needs to be in the server's configuration file.
    In my situation, the configuration for the non-SSL and SSL-enabled variants were in a separate files. The non-SSL configuration had AllowOverride All all along, and so everything was working fine. Once I had enabled the SSL, the other configuration file came into play and didn't have the required AllowOverride All setting."


    Niestety, nie mam dostępu, żeby coś takiego wprowadzić.

    Czy zna ktoś rozwiązanie tego problemu?
     
  2. casar

    casar Profesjonalista

    Wiadomości:
    452
    Docenione treści:
    122
    Aby Wordpress działał z certyfikatem musisz użyć którejś wtyczki.
    Jeśli udało Ci się doprowadzić do działania, a po kilku wizytach dostałaś 500, to nie musi być wina konfiguracji. Spróbuj ta konfigurację ustawić jeszcze raz.
     
  3. Luinehil

    Luinehil Nowy użytkownik

    Wiadomości:
    2
    Docenione treści:
    0
    Próbowałam różnych konfiguracji i różnych wtyczek. Problem leży w serwerze home.pl - przekierowałam domenę i SSL na inny hosting, u konkurencji, na razie wszystko działa. :)
     
  4. casar

    casar Profesjonalista

    Wiadomości:
    452
    Docenione treści:
    122
    Po wielu próbach i sprawdzeniu kilku rozwiązań z Google'a, znalazłem rozwiązanie, ale nie znam przyczyny konieczności jego zastosowania.

    PHP:
    $_SERVER['HTTPS']='on';
    Wystarczyło dodać ten zapis w wp-config.php
     

Poleć forum znajomym