1. Forum używa plików Cookies. Dowiedz się więcej o celu ich używania i możliwości zmiany ustawień Cookies w przeglądarce. Czytaj więcej...

ROZWIĄZANE Instalacja frameworka Symfony w wersji 3.0

Dyskusja w 'Hosting Business Cloud' rozpoczęta przez użytkownika maciejjeziorski, 7 Maj 2016.

  1. maciejjeziorski

    maciejjeziorski Nowy użytkownik

    Wiadomości:
    2
    Docenione treści:
    1
    Witam,

    Mam problem z zainstalowaniem frameworku Symfony w wersji 3.0 na serwerze Home.pl. Prawdopodobnie jakieś ustawienia serwera wymagają dodatkowych modyfikacji plików .htaccess bądź php.ini, jednak nie jestem pewien co może powodować wysypywanie się aplikacji.

    Problem z serwerami Home.pl jest taki, że nie jest to czysta instalacja serwera Apache, tylko autorski system i w związku z tym, podczas gdy na innych serwerach wszystko działa bez zarzutow, to na Home trzeba kombinować. Wersja 2.7 działa bez zarzutów (oczywiście po wprowadzeniu koniecznych poprawek), jednak 3.0 nie mogę uruchomić. Wyświetla się taki błąd, gdy próbuję wejść na mojastrona.pl/web/app_dev.php:


    Dla wersji 2.7 zawsze ustawiałem pliki w taki sposób:

    /.htaccess
    PHP:
    RewriteEngine On
    RewriteBase 
    /

    RewriteRule ^$ web/$[QSA,L]
    RewriteRule ^(.*)$ web/$[QSA,L]

    # Enable PHP 5.6
    :Location *.php
    Use php56

    /web/.htaccess
    PHP:
    # W TYM PLIKU WYŁĄCZNIE ZAKOMENTOWANIE TYCH DWÓCH LINIJEK
    # RewriteCond %{ENV:REDIRECT_STATUS} ^$
    # RewriteRule ^app\.php(?:/(.*)|$) %{ENV:BASE}/$1 [R=301,L]
    # RESZTA BEZ ZMIAN

    Niestety tym razem to rozwiązanie nie działa i wywala błąd. Czy ktoś z Was instalował już Symfony 3.0? Z czego on może wynikać?
     
  2. Grzesiek

    Grzesiek BOK home.pl home.pl Administrator forum

    Wiadomości:
    3 339
    Docenione treści:
    315
    Skonsultowałem to z chłopakami z zespołu technicznego (tak tak, czuwają) i nawet zainstalowaliśmy to, wszystko ok jest, co wskazuje że błąd leży gdzieś po stronie Twojego projektu, może w ogóle go nie utworzyłeś.

    Downloading Symfony...

    4.98 MB/4.98 MB ▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓ 100%

    Preparing project...

    ✔ Symfony 3.0.5 was successfully installed. Now you can...


    Ogólnie zrób tak jak na stronie oficjalnej symfony za pomocą composera

    U nas tego nie ma, więc wchodzisz przez SSH na serwer do głównego katalogu i odpalasz

    curl -LsS https://symfony.com/installer -o symfony-installer

    chmod a+x symfony-installer

    php56-cli symfony-installer new nazwa_projektu

    Ten skrypt pokaże już wszystko co musisz edytować/zmienić

    Później odpalasz server wchodząc do katalogu nazwy_projektu (cd moj_projekt)

    php56-cli bin/console server:run

    Nasz kolega skorzystał z tej metody na swojej maszynie, tylko bez odpalania serwera, bez opcji php56-cli bin/console server:run

    za pomocą tego : php56-cli bin/console server:run - można odpalić osobny serwer WWW nasłuchujący na innym porcie np. 8080, 9000 itp.
     
    maciejjeziorski lubi to.
  3. maciejjeziorski

    maciejjeziorski Nowy użytkownik

    Wiadomości:
    2
    Docenione treści:
    1
    Grzesiek, dziękuję za przyjrzenie się sprawie. Całość była o tyle trudna, że jest to serwer z linii ekonomicznej, a więc bez SSH i w związku z czym musiałem instalować najpierw u siebie, a dopiero potem przerzucać pliki na serwer. Problem okazał się trywialny. Należało, poza instalacją:

    php symfony new my_project

    zainstalować assetsy:

    php bin/console assets:install

    Podczas instalacji powinno to być czymś wykonywanym automatycznie, ale niestety trzeba to robić ręcznie.
    Problem został rozwiązany.
     
    Mariusz lubi to.
  4. kajetan_dev

    kajetan_dev Nowy użytkownik

    Wiadomości:
    1
    Docenione treści:
    0
    Mam problem. Próbowałem zainstalować symfony jak w wyżej wymienionej instrukcji, lecz przy odpaleniu komendy php56-cli bin/console server:run wyświetla mi się komunikat : "Fatal Error bad file descriptor (9)".
     
  5. Grzesiek

    Grzesiek BOK home.pl home.pl Administrator forum

    Wiadomości:
    3 339
    Docenione treści:
    315
    FEEDBACK-1171 temat przekazany do weryfikacji.
     
  6. Mariusz

    Mariusz BOK home.pl home.pl Administrator forum

    Wiadomości:
    3 050
    Docenione treści:
    300
    W ramach zgłoszenia FEEDBACK-1171 otrzymałem informacje, że nasi administratorzy znaleźli przyczynę tego błędu, zgłoszenie zostało zakolejkowane do rozwiązania w ramach następnego zgłoszenia o numerze: ZRSI-5141. Niestety w tej chwili nie jest znany dokładny termin jego realizacji.

    W tej chwili zmieniam status tematu na "W trakcie". Będę na bieżąco informował, gdy status zgłoszenia ZRSI-5141 zostanie zmieniony na rozwiązane.
     
  7. Mariusz

    Mariusz BOK home.pl home.pl Administrator forum

    Wiadomości:
    3 050
    Docenione treści:
    300
    Zgłoszenie zostanie rozwiązane w ramach aktualizacji HomeSSH, którą niebawem planujemy. Problemem przy instalacji frameworka Symfony w wersji 3.0 jest brak katalogu /tmp w środowisku budowanym pod SSH. Więcej informacji przekażę, gdy zostanie zaplanowany termin aktualizacji.
     
  8. Mariusz

    Mariusz BOK home.pl home.pl Administrator forum

    Wiadomości:
    3 050
    Docenione treści:
    300
    Otrzymałem informacje od programistów, że instalacja frameworka Symfony powinna już być możliwa na naszym hostingu (zarówno na IdeaHosting jak i na Apache). Zapraszam do sprawdzania i testowania, ustawiam temat na forum jako rozwiązany.

    Przepraszamy za długi okres oczekiwania.
     

Poleć forum znajomym