1. Forum używa plików Cookies. Dowiedz się więcej o celu ich używania i możliwości zmiany ustawień Cookies w przeglądarce. Czytaj więcej...

W TRAKCIE Jak skonfigurować SwiftMailer

Dyskusja w 'Poczta home.pl' rozpoczęta przez użytkownika LorK, 15 Sierpień 2016.

  1. LorK

    LorK Przyjaciel forum Beta-tester

    Wiadomości:
    1 002
    Docenione treści:
    88
    Cały dzień walczę i bez wyraźnych skutków :/
    Mam skrypt http://swiftmailer.org/, którego nie potrafię ustawić by wysyłał mi wiadomości po SSLu. Mogę wysłać SMTP:587 ale już SSL-SMTP:465 nie działa.
    Nie mam certyfikatu więc korzystam z tego serwerowego. Z Thunderbirda działa - więc login, hasło i adres serwera są ok.
    Włączyłem sobie dubuga... ale to nie pomogło.

    Może ktoś, coś wie w temacie i może poratować?
     
  2. Grzesiek

    Grzesiek Centrum Pomocy home.pl Administrator forum

    Wiadomości:
    3 555
    Docenione treści:
    325
    Czyli nazwa_serwera.home.pl jako adres serwera SMTP, nazwa użytkownika: pełny adres e-mail, hasło. Powinno działać, czy jakieś konkretne komunikaty błędów zwraca? Jeśli taka konfiguracja nie działa, aktywuj wysyłkę i podaj datę/godzinę/adres skonfigurowanego konta, postaramy się dowiedzieć coś więcej może z logów serwera.
     
  3. LorK

    LorK Przyjaciel forum Beta-tester

    Wiadomości:
    1 002
    Docenione treści:
    88
    Nakreślę sprawę jeszcze raz. Wpisuję login (pełny email), hasło, adres serwera SMTP (w schemacie nazwa_serwera.home.pl). Ustawiam port 587, szyfrowanie - brak. Wysyłka działa. Czyli adres serwera, nadawców, odbiorców oraz wszystkie wymagane nagłówki są ustawione poprawnie.

    Idę dalej: zmieniam port na 465, encryption na SSL... i zaczynają się problemy.
    Włączyłem sobie debuga. Z niego wynika, że serwer strzela timeouta.

    Odpalam telnet - łącze się nim na adres serwera SMTP, na porcie 587 - mogę pogadać z serwerem.
    Próbuję połączyć się telnetem na 465 i mam timeout... (nie wiem czy serwer powinien odpowiedzieć czy nie w takiej konfiguracji).

    No ale dobra - myślę sobie, że nie będę nękał supportu, sam pokombinuję. SSHuję się na serwer, robię grepa w logach serwera email a tam nic nie ma. Nie wiem czy powinno być.

    Na swoje usprawiedliwienie dodam, że dużo googlowałem (wiele ludzi ma z tym problem widzę) ale rozwiązania nie znalazłem.

    @Grzesiek Adresy email oraz dane "tajne" poszły na PW.

    Dane jakie zwraca wtyczka debugera:
    Kod:
    ++ Starting Swift_SmtpTransport
    
    << 220 **********.home.net.pl ESMTP IdeaSmtpServer v0.80.3 ready.
    
    
    !! Connection to ssl://*****.home.pl:465 Timed Out (code: 0)
    
    >> HELO test.lork.pl
    
    
    << 250*****.home.net.pl Hello *****.home.net.pl [79.96.146.71], pleased to meet you
    250-PIPELINING
    250-ENHANCEDSTATUSCODES
    250-SIZE
    250-8BITMIME
    250-AUTH PLAIN LOGIN
    250-AUTH=PLAIN LOGIN
    250 HELP
    
    
    ++ Swift_SmtpTransport started
    
    >> MAIL FROM:<*****@*****.pl>
    
    
    << 250 *****.home.net.pl Hello *****.home.net.pl [79.96.146.**], pleased to meet you
    
    
    >> RCPT TO:<*****@*****.pl>
    
    
    << 250 2.1.0 Sender address accepted
    
    
    >> DATA
    
    
    << 250 2.1.5 Recipient address accepted
    
    
    !! Expected response code 354 but got code "250", with message "250 2.1.5 Recipient address accepted
    " (code: 250)
    
    ++ Stopping Swift_SmtpTransport
    
    >> QUIT
    
    
    << 354 Go ahead...
    
    
    !! Expected response code 221 but got code "354", with message "354 Go ahead...
    " (code: 354)
    
    ++ Swift_SmtpTransport stopped
    (dodam tylko, że skrypt uruchamiany jest raz i funkcja wysyłająca też jest odpalana raz).
     
    Last edited by a moderator: 17 Sierpień 2016
  4. Grzesiek

    Grzesiek Centrum Pomocy home.pl Administrator forum

    Wiadomości:
    3 555
    Docenione treści:
    325
    Wystawiłem zgłoszenie, zapomniałem podesłać: FEEDBACK-725 czekamy
     
    Mariusz i LorK lubią to.
  5. RafalxM

    RafalxM Nowy użytkownik

    Wiadomości:
    1
    Docenione treści:
    0
    mam podobny problem, nie mogę połączyć się z zewnątrz do SMTP home.pol .
    Przez kilka lat działało i nagle przestało.

    także to zgłaszałem , numer ticket'u: JFGN-84618-325
     
  6. Stau

    Stau Majster

    Wiadomości:
    340
    Docenione treści:
    98
    Jeśli chcesz "pogadać" z serwerem SMTP na "szyfrowanym" porcie musisz użyć openSSL-a. Wpisz w konsoli:
    - openssl s_client -connect serwerXXXXX.home.pl:465
     
  7. TheL

    TheL @Lider VIP Moderator forum

    Wiadomości:
    2 363
    Docenione treści:
    520
    samo połączenie szyfrowane działa i sprawdziłem to przed chwilą z php, czy masz jakikolwiek wpis w logu mailowym na serwerze?
     
  8. Mariusz

    Mariusz pomoc.home.pl home.pl Administrator forum

    Wiadomości:
    3 060
    Docenione treści:
    300
    @LorK nasi administratorzy potwierdzili mi, że połączenie po porcie szyfrowanym funkcjonuje poprawnie.

    Output debugera, który podałeś jest trochę dziwny - niby jest timeout, ale dalej otwiera się sesja SMTP. Przykładowo, wysyła polecenie mail from zanim nasza Idea odpowie swoim bannerem SMTP. Najprawdopodobniej z tego powodu skrypt się gubi, bo oczekuje innych odpowiedzi niż dostaje. Skrypt dostaje od nas dobre odpowiedzi - zgodne z RFC, a wysyła do nas dobre komendy, ale w złej kolejności (niezgodnie z RFC).

    Podsumowując, albo ten skrypt nie umie rozmawiać z SMTP, albo za szybko wysyła komendy. Proponujemy, żebyś przesłał jeszcze jeden output z debuggera i/lub zgłosił się do supportu/producenta aplikacji.

    Nasze serwery działają poprawnie, nie mamy innych podobnych zgłoszeń.
     
  9. LorK

    LorK Przyjaciel forum Beta-tester

    Wiadomości:
    1 002
    Docenione treści:
    88
    @Stau - dzięki
    @TheL - raczej pusto
    @Mariusz - to, że logi są dziwne to sam zauważyłem (co subtelnie zaznaczyłem, w moim poście). Z SMTP on potrafi gadać - jak wyłączę szyfrowanie wszystko jest ok. Z tego co wiem to ten skrypt jest używany przez Symfony, więc pewnie zgodność posiada.

    Może macie jakiś skrypt, który wiecie że działa na serwerach home (najlepiej z SMTP SSL)?
     
  10. Mariusz

    Mariusz pomoc.home.pl home.pl Administrator forum

    Wiadomości:
    3 060
    Docenione treści:
    300
    @TheL @Stau @casar korzystaliście może kiedyś z jakiegoś takiego skryptu, który moglibyście polecić?
     
  11. TheL

    TheL @Lider VIP Moderator forum

    Wiadomości:
    2 363
    Docenione treści:
    520
    Działa stara wersja php mail list, nowe niestety są już płatne, zresztą większość dobrych skryptów mailingowych stała się płatna.
     
    Mariusz lubi to.
  12. LorK

    LorK Przyjaciel forum Beta-tester

    Wiadomości:
    1 002
    Docenione treści:
    88
    @TheL a możesz jakiegoś linka zapodać? Google wyrzuca mi jakieś "głupoty".
     
  13. LorK

    LorK Przyjaciel forum Beta-tester

    Wiadomości:
    1 002
    Docenione treści:
    88

    albo chociaż jak ustawić SwiftMailera.
     
  14. TheL

    TheL @Lider VIP Moderator forum

    Wiadomości:
    2 363
    Docenione treści:
    520
    php mail list szukaj starej wersji nowa jest płatna.
    A co do swifta to masz go z GITa?
     
  15. LorK

    LorK Przyjaciel forum Beta-tester

    Wiadomości:
    1 002
    Docenione treści:
    88
    tak. Czemu pytasz?
     
  16. TheL

    TheL @Lider VIP Moderator forum

    Wiadomości:
    2 363
    Docenione treści:
    520
    bo rano sam go zainstaluję i sprawdzę dziś czeka zabawa z Raspberry PI i VPN :D
     
  17. LorK

    LorK Przyjaciel forum Beta-tester

    Wiadomości:
    1 002
    Docenione treści:
    88
    offtopic: ja się też dziś bawiłem z VPNem... aż mnie serwer zdalny zablokował ;) Publikujesz gdzieś te swoje zabawy z R-PI?
     
  18. casar

    casar Profesjonalista

    Wiadomości:
    463
    Docenione treści:
    122
    Nie, nie korzystałem z tego typu rozwiązań.
     
  19. TheL

    TheL @Lider VIP Moderator forum

    Wiadomości:
    2 363
    Docenione treści:
    520
    tak jak pisałem, rano uruchomię Swifta i myślę, że uda się go zmusić do działania.
    Ja nigdzie nie publikuję rozwiązań Raspberry PI one działają jako produkcyjne maszynki :)
     
  20. Mariusz

    Mariusz pomoc.home.pl home.pl Administrator forum

    Wiadomości:
    3 060
    Docenione treści:
    300
    udało coś Ci się z tym wykombinować? Może mi się uda do tego dokładnie przysiąść, ale to dopiero po weekendzie :(.
     

Poleć forum znajomym