1. Forum używa plików Cookies. Dowiedz się więcej o celu ich używania i możliwości zmiany ustawień Cookies w przeglądarce. Czytaj więcej...

Nowa wersja Joomli 3.9.11 - brak możliwości logowania się użytkowników.

Dyskusja w 'WordPress, Joomla!, PHP, HTML, CSS' rozpoczęta przez użytkownika pcserwis.a_w, 3 Wrzesień 2019.

  1. pcserwis.a_w

    pcserwis.a_w Nowy użytkownik

    Wiadomości:
    2
    Docenione treści:
    0
    Mam gorącą prośbę o pomoc. Od wersji 3.9.10 - użytkownicy stworzeni w środowisku nie mogą się zalogować swoimi hasłami. w wersji 3.9.9 i wcześniejszych wszystko było O'K.
    Nie mogę wpaść na pomysł.
     
  2. casar

    casar Profesjonalista

    Wiadomości:
    469
    Docenione treści:
    122
    Sprawdziłem u siebie - na wersji 3.9.11 logowanie działa. Jakieś komunikaty przy logowaniu mają użytkownicy?
    Może masz przepełniony serwer i nie może np. tworzyć plików sesji?
     
  3. pcserwis.a_w

    pcserwis.a_w Nowy użytkownik

    Wiadomości:
    2
    Docenione treści:
    0
    Nie ma żadnego komunikatu podczas logowania tylko wyrzuca do panelu logowania raz jeszcze z pytaniami :
    Nie sądzę, żebym miał coś przepełnione - zasoby na poziomie 20% zajętości.
    Oczywiście admin od zaplecza i od frontu loguje się normalnie.
    Przykładowy user może się zalogować tylko w przypadku gdy ma przywileje Administratora lub Superuser-a.
    Poprzednio tworzony użytkownik miał przywilej Gościa i też się logował ....


    Może chodzi o ostrzeżenie na pulpicie :
    Ostrzeżenie
    Your PHP version, 7.1.26, is only receiving security fixes from the PHP project at this time. .......
    tylko jak zmieniam wersje na wyższą do wywala mi błędy na stronie głównej :
    Deprecated: Function create_function() is deprecated in autoinstalator/joomla1/libraries/rokcommon/RokCommon/Service/ContainerImpl.php on line 460

    OK - Rocksprocet-a wywaliłem,
    Obecna biblioteka PHP to 7.3.1,
    Błędów na stronie głównej już nie wywala,

    PROBLEM POZOSTAŁ .....
     
    Ostatnia modyfikacja: 4 Wrzesień 2019
  4. casar

    casar Profesjonalista

    Wiadomości:
    469
    Docenione treści:
    122
    Zauważyłem u siebie, że samo ustawienie grupy Gość nie pozwala na zalogowanie. Jak dodałem Registered to się udało:
    upload_2019-9-4_18-49-41.png
    Aczkolwiek nie bardzo orientuję się w tych ustawieniach dostępu w Joomli i chyba Registered ma trochę za dużo uprawnień jak na Gościa. No i nie widzę opcji gdzie można by wskazać, które elementy są dostępne tym grupom.
    Przypuszczam, jednak że tu mogło się coś zmienić, ale specjalistą od Joomli nie jestem, nie wiem jak było przed aktualizacją.
     
  5. gielo2

    gielo2 Asystent

    Wiadomości:
    146
    Docenione treści:
    18
    Proponuję powyłączać dodatki jak masz uruchomione jakieś, szczególnie zewnętrzne (od osób trzecich). To, że joomla wspiera jakąś noszą wersję PHP, nie znaczy że pluginy tez są z nią 100% zgodne. Prawdopodobnym jest też, że jest jakiś bug w samej Joomli, który ujawnia się przy jakiejś specyficznej konfiguracji serwera www. Jeśli nie uda ci się namierzyć problemu, zgłoś to jako bug na https://issues.joomla.org/
     
  6. Grzesiek

    Grzesiek Centrum Pomocy home.pl Administrator forum

    Wiadomości:
    3 564
    Docenione treści:
    325
    Najlepszym rozwiązaniem będzie to wskazanie przez gielo2. PHP jest rozwiązaniem kontrolowanym odgórnie, a przy obecnej achitekturze serwerów, wykluczamy raczej błędy po stronie serwera. Wyłącz wtyczki i uruchamiaj kolejne.
     

Poleć forum znajomym