1. Forum używa plików Cookies. Dowiedz się więcej o celu ich używania i możliwości zmiany ustawień Cookies w przeglądarce. Czytaj więcej...

ROZWIĄZANE PHP 7.1 - kiedy?

Dyskusja w 'Sugestie i zgłoszenia' rozpoczęta przez użytkownika LorK, 28 Grudzień 2016.

  1. LorK

    LorK Przyjaciel forum Beta-tester

    Wiadomości:
    1 036
    Docenione treści:
    91
    Witam,

    kiedy będzie PHP 7.1 na Home.pl? :)

    Pozdrawiam
     
  2. Grzesiek

    Grzesiek Centrum Pomocy home.pl Administrator forum

    Wiadomości:
    3 594
    Docenione treści:
    329
    Mówisz i zgłaszam... FEEDBACK-1009
     
  3. Grzesiek

    Grzesiek Centrum Pomocy home.pl Administrator forum

    Wiadomości:
    3 594
    Docenione treści:
    329
    Wg. informacji jakie uzyskałem termin wdrożenia to styczeń/luty, czy jednak będzie to test (wybrane serwery + feedback na forum) czy pełne wdrożenie na wszystkich maszynach, tego jeszcze nie wiem. Ale realizacja jest bliska.
     
  4. LorK

    LorK Przyjaciel forum Beta-tester

    Wiadomości:
    1 036
    Docenione treści:
    91
    to czekam czekam :)
     
  5. Mariusz

    Mariusz pomoc.home.pl home.pl Administrator forum

    Wiadomości:
    3 087
    Docenione treści:
    302
    Wdrożenie jest zaplanowane na przełomie stycznia/lutego, ale proszę nie traktować tego jeszcze jako zobowiązującej informacji.
     
  6. xandros

    xandros Bywalec

    Wiadomości:
    18
    Docenione treści:
    4
    Jak mogę aktywować php7.1 na serwerze i czy jest to możliwe przez .htaccess?
     
  7. Grzesiek

    Grzesiek Centrum Pomocy home.pl Administrator forum

    Wiadomości:
    3 594
    Docenione treści:
    329
    http://php.home.pl/ 7.0 ostanie, złożę zapytanie czy testujemy wyższe wersje już i odezwę się jak coś dowiem. Zapewne w poniedziałek, ok?
     
  8. xandros

    xandros Bywalec

    Wiadomości:
    18
    Docenione treści:
    4
  9. xandros

    xandros Bywalec

    Wiadomości:
    18
    Docenione treści:
    4
  10. Grzesiek

    Grzesiek Centrum Pomocy home.pl Administrator forum

    Wiadomości:
    3 594
    Docenione treści:
    329
    Nic, poza tym że 7.1 w zasadzie kończy testy u nas. Nie podam Ci daty wdrożenia, ale temat jest na szczycie listy DO WDROŻENIA.
     
  11. Mariusz

    Mariusz pomoc.home.pl home.pl Administrator forum

    Wiadomości:
    3 087
    Docenione treści:
    302
    W ramach zgłoszenia o numerze FEEDBACK-1009 otrzymałem informacje, że już niebawem 7.1 zostanie wprowadzone na wszystkich naszych serwerach. Aktualizacja już powoli roznosi się po serwerach. Tydzień lub dwa tygodnie i PHP 7.1 będzie dostępne na wszystkich serwerach.
     
    LorK lubi to.
  12. Adam

    Adam Social Media home.pl home.pl Administrator forum

    Wiadomości:
    262
    Docenione treści:
    73
  13. xandros

    xandros Bywalec

    Wiadomości:
    18
    Docenione treści:
    4
  14. Adam

    Adam Social Media home.pl home.pl Administrator forum

    Wiadomości:
    262
    Docenione treści:
    73
    @xandros Na moje oko różnice między 7.1 a 7.2 nie będą dla większości widoczne i odczuwalne, ale na pewno będziemy badać temat wprowadzenia 7.2 w przyszłości.
     
    LorK lubi to.
  15. xandros

    xandros Bywalec

    Wiadomości:
    18
    Docenione treści:
    4
    > Na moje oko różnice między 7.1 a 7.2 nie będą dla większości widoczne

    Wiekszości wystarczyłby php5.3 z wordpressem, ale przyśpieszenie działania skryptu, typehint object, nadpisywanie metod abstrakcyjnych, poprawki w bezpieczeństwie i różne inne fixy.

    Tak czy inaczej dalej nie ma php7.1 na cli:

    Kod:
     
    php71-cli composer.phar install
    Sun Sep  3 16:38:13 2017 (1775): Fatal Error Unable to create lock file: Bad file descriptor (9)
    
    a przy php7-cli:

    Kod:
    php7-cli composer.phar install
    Loading composer repositories with package information
    Installing dependencies (including require-dev) from lock file
    Your requirements could not be resolved to an installable set of packages.
    
      Problem 1
        - This package requires php >=7.1 but your PHP version (7.0.19) does not satisfy that requirement.
    
    
     
  16. Mariusz

    Mariusz pomoc.home.pl home.pl Administrator forum

    Wiadomości:
    3 087
    Docenione treści:
    302
    @xandros PHP 7.1 na cli jest dostępne, ale composera u nas w chwili obecnej nie zainstalujesz. Mamy jednak to w planach wprowadzić, aby instalacja composera była możliwa na hostingu współdzielonym w home.pl.
     
  17. xandros

    xandros Bywalec

    Wiadomości:
    18
    Docenione treści:
    4
    > PHP 7.1 na cli jest dostępne

    pod komendą php71-cli?
    Kod:
     
    php7-cli -v
    PHP 7.0.19 (cli) (built: Jul 13 2017 08:07:47) ( NTS )
    Copyright (c) 1997-2017 The PHP Group
    Zend Engine v3.0.0, Copyright (c) 1998-2017 Zend Technologies
        with the ionCube PHP Loader (enabled) + Intrusion Protection from ioncube24.com (unconfigured) v6.0.9, Copyright (c) 2002-2016, by ionCube Ltd.
        with Zend OPcache v7.0.19, Copyright (c) 1999-2017, by Zend Technologies
    
    Kod:
     php71-cli -r "echo 'hello world';"
    Mon Sep  4 15:29:32 2017 (26298): Fatal Error Unable to create lock file: Bad file descriptor (9)
    
    > composera u nas w chwili obecnej nie zainstalujesz

    Nie chcę instalować (globalnie). Tylko jego użyć do instalacji/aktualizacji pakietów w DI.
     
  18. Mariusz

    Mariusz pomoc.home.pl home.pl Administrator forum

    Wiadomości:
    3 087
    Docenione treści:
    302
    @xandros

    AD1. Tak, jest dostępne.
    AD2. Na hostingu współdzielonym nie uda Ci się użyć composera. Znamy ten temat i mamy to w planach poprawić (frameworki są na roadmapie, ale czas wprowadzenia zmian odnośnie composera jest w tej chwili jeszcze nieznany).
     
  19. xandros

    xandros Bywalec

    Wiadomości:
    18
    Docenione treści:
    4
    AD.1 Pod jaką komendą? Bo jak wpisuję php71-cli, to serwer zwraca błąd z bad file descriptor.

    Czy muszę uruchomić to w panelu administracyjnym?
     
  20. Mariusz

    Mariusz pomoc.home.pl home.pl Administrator forum

    Wiadomości:
    3 087
    Docenione treści:
    302
    "Bad file descriptor" jest komunikatem związanym właśnie z niedogodnościami z instalacją/użyciem composera na naszym hostingu współdzielonym.

    Aby skorzystać z php71-cli należy używać poleceń w formacie:
    Kod:
    php71-cli skrypt.php
     

Poleć forum znajomym