1. Forum używa plików Cookies. Dowiedz się więcej o celu ich używania i możliwości zmiany ustawień Cookies w przeglądarce. Czytaj więcej...

Testy nowego interpretera php w wersji 7.0

Dyskusja w 'Testy nowego interpretera php w wersji 7.0' rozpoczęta przez użytkownika Grzesiek, 13 Styczeń 2016.

  1. Grzesiek

    Grzesiek Centrum Pomocy home.pl Administrator forum

    Wiadomości:
    3 587
    Docenione treści:
    328
    Cześć!

    Miło mi poinformować, iż w ramach usług hostingu współdzielonego w home.pl, w dniu dzisiejszym, 13 stycznia, uruchomiliśmy testowo nowy interpreter PHP w wersji 7.0. Interpreter PHP w wersji 7 działa wraz z mechanizmem OPCACHE, który jakiś czas temu został wdrożony na serwerach home.pl.

    Informacje dot. nowej wersji interpretera PHP, znajdziecie m.in. TUTAJ

    [​IMG]

    Interpreter jest aktywny na wszystkich usługach linii ekonomicznej i profesjonalnej, a także usłudze Wordpress Hosting SDD i Click Shop.

    W chwili obecnej, uruchomienie interpretera PHP nie jest dostępne z poziomu panelu administracyjnego, a możliwie jedynie poprzez dodanie na serwerze FTP w katalogu głównym lub podkatalogu, pliku .htaccess, który uruchomi wybraną wersję interpretera.

    Umieszczenie pliku .htaccess zależne jest od tego, czy ma on być aktywny dla całego serwera (katalog główny) czy tylko dla wybranego serwisu/katalogu (podkatalog).

    Interpreter uruchomiony został testowo i nie posiada jeszcze aktywnych wszystkich modułów. Sugerujemy aby nie uruchamiać go w chwili obecnej na serwisach WWW, które wymagają stałej aktywności w sieci.

    W przypadku zaobserwowania niedogodności w działaniu stron/skryptów, stwierdzenia błędów oraz chęci podzielenia się wrażeniami z nowej funkcjonalności, zapraszamy do dyskusji na forum.home.pl. Wszystkie informacje zwrotne, zostaną przekazane do kierownika produktu oraz zespołu technicznego, celem poprawnego wdrożenia nowego interpretera.

    Więcej informacji:
     
    Ostatnia modyfikacja: 13 Styczeń 2016
  2. gielo2

    gielo2 Asystent

    Wiadomości:
    148
    Docenione treści:
    21
    Fajnie, że zdecydowaliście się na odpalenie jego najnowszej wersji. Właśnie odpaliłem go dla kilku stron opartych na WP i działa świetnie :) Nie mogę go jednak odpalić na clickshopie jako, że w panelu admina w opcjach gdzie można dopisać reguły .htaccess, poniżej jest okienko w którym nie da się nic modyfikować, a w nim wymuszany jest php54 i najzwyczajniej cokolwiek bym nie wpisał w tym powyższym to to poniższe mi wymusza starsza wersję php5.4. Da się to jakoś zmienić, czy tak ma być?

    Ps. Po dopisaniu jeszcze niżej reguł odpowiedzialnych za zmianę wersji PHP zdają si uruchamiać go i dla samego sklepu. Jeden z pracowników zgłaszał mi jednak błąd przy paczkomatach, a dokładnie przy generowaniu przesyłki z zamówienia. Po usunięciu tych reguł i powrocie do starszej wersji PHP wszystko z mety znowu zaczęło działać poprawnie. Jak na razie w ClickShopie tylko z tym zauważyłem problem. strony na WP śmigają aż milo :).
     
    Ostatnia modyfikacja: 20 Styczeń 2016
  3. Mariusz

    Mariusz pomoc.home.pl home.pl Administrator forum

    Wiadomości:
    3 084
    Docenione treści:
    301
    @gielo2 zgadza się, wystarczy dodać poniższą regułkę w polu, który znajduje się pod zablokowanym polem (przedstawiam to na obrazku poniżej). Spowoduje to włączenie nowej testowej wersji PHP 7. Dziękuję za zgłoszenie informacji o błędach w paczkomatach, a dokładnie przy generowaniu przesyłki z zamówienia. Przekazałem je dalej do zespołu produktowego, aby to zweryfikowali.
    Kod:
    :Location /*.php
    Use php7
    :Location
    htaccess21.png
     
  4. Mariusz

    Mariusz pomoc.home.pl home.pl Administrator forum

    Wiadomości:
    3 084
    Docenione treści:
    301
    Dodam jeszcze, że PHP w wersji 7 uruchomiliśmy testowo, aby nasi Klienci mogli sprawdzić wersję 5.7 przy swoich serwisach WWW. Przyznaję, że Click Shop nie jest jeszcze w 100% gotowy na 7.0. Musimy jeszcze po naszej stronie dostosować "parę rzeczy" - działamy w pocie czoła, aby zrealizować to w jak najkrótszym terminie.

    Z tego powodu sugerujemy przy sklepach korzystać jeszcze z wersji PHP 5.6, przy której Click Shop działa prawidłowo.
     
  5. TheL

    TheL @Lider VIP Beta-tester

    Wiadomości:
    2 364
    Docenione treści:
    521
    trwają właśnie testy 7ki odnośnie szybkości na hostingu współdzielonym, wyniki podam w najbliższym czasie.
     
    Mariusz lubi to.

Poleć forum znajomym