1. Forum używa plików Cookies. Dowiedz się więcej o celu ich używania i możliwości zmiany ustawień Cookies w przeglądarce. Czytaj więcej...

ROZWIĄZANE wyświetlanie domeny dla podkatalogów

Dyskusja w 'Wordpress Hosting SSD' rozpoczęta przez użytkownika Gregdob, 28 Listopad 2017.

  1. Gregdob

    Gregdob Początkujący

    Wiadomości:
    6
    Docenione treści:
    3
    Witam,
    Jako laik korzystałem z wordpress.com ale szybko zauważyłem, że nie daje on wystarczającej elastyczności więc zdecydowałem się na zbudowanie nowej strony w oparciu o WP na home.pl

    Po odpięciu domeny ze starego hostingu mam problem z prawidłowym wyświetlaniem adresu.

    Dla strony głównej wszystko jest OK. Po wpisaniu mojadomena.pl wyswietla się strona główna

    Dla innej strony np. Kontakt wyświetla się http://serwer1xxxxx.home.pl/autoinstalator/wordpress/kontakt/ zamiast mojadomena.pl/kontakt/

    Wczoraj po wpisaniu domeny do Ustawień WP na początku mi się 'rozkwaśiło' więc po wielu probach udało mi sie w bazie zmienić pierwotne. Teraz mam tak:
    Ustawienie 1:
    WordPress Address (URL): http://serwer1xxxxxx.home.pl/autoinstalator/wordpress
    Site Address (URL): http://serwer1xxxxxx.home.pl/autoinstalator/wordpress

    Ustawienie 2:
    Po wpisaniu do Site URL: http://mojadomena.pl wyswietla się tylko strona głowna a dla innych stron mam błąd:
    404 Not Found
    The request /kontakt/ was not found on this server.

    Co jest nie tak? Podejrzewam że może chodzić o zmianę w pliku index.php lub .htaccess bo tu były próby zarówno w katalogu public_html jak i w public_html/autoinstalator/wordpress.
    A może jeszcze coś.

    Dodam że w przekierowaniu domen mam: "przekierowanie na podkatalog bez separacji serwisu" do /autoinstalator/wordpress/

    Z góry dzięki za pomoc
     
    Ostatnia modyfikacja: 28 Listopad 2017
  2. Gregdob

    Gregdob Początkujący

    Wiadomości:
    6
    Docenione treści:
    3
    Po zmianach w Permalinks z "Day and name" na "Plain" zaczęło pokazywać jak należy, ale ... co jeśli nadal chcę mieć Pretty Permalinks?
     
  3. Mariusz

    Mariusz BOK home.pl home.pl Administrator forum

    Wiadomości:
    3 043
    Docenione treści:
    300
    W ustawieniach bezpośrednich odnośników na swoim WordPressie mam ustawione "Własny format" o wartości:
    Kod:
    %category%/%postname%
    W ustawieniach WordPressa (u mnie nazywa się to ustawienia ogólne) w polach Adres WordPressa (URL) oraz
    Adres witryny (URL) powinieneś mieć wpisany adres swojej domeny, czyli mojadomena.pl
    Pretty Permalinks to jakieś rozszerzenie? Niestety go nie znam, mogę tylko podpowiedzieć ustawienia dla WordPressa.
     
  4. Gregdob

    Gregdob Początkujący

    Wiadomości:
    6
    Docenione treści:
    3
    Dzięki. Ale po wpisaniu mojadomena.pl w obu miejscach cały WP admin mi się rozkrzaczył i trzeba było zmieniać z palca w bazie MySQL. Już nie pamiętam czy wpisywałem mojadomena.pl czy też mojadomena.pl/autoinstalator/wordpress/.
    A jak jest u Ciebie?

    P.S. Pretty Permanlinks - też nie wiedziałem - ale to między innymi to co Ty masz ustawione (np. %category%/%postname%) a nie jakieś odnośniki do post ID - podobno lepiej mieć pretty peramlinks dla SEO
     
  5. Gregdob

    Gregdob Początkujący

    Wiadomości:
    6
    Docenione treści:
    3
    Dzięku @Mariusz , Jednak tak powinno być jak piszesz tylko trzeba mieć przekierowanie ustawione odpowiednio. Problem był, że się zapętlał i w pewnym momencie wyrzucał do public_html.

    Generalnie powinno być tak:
    1. W ustawieniach ogólnych w polach Adres WordPressa (URL) oraz Adres witryny (URL) - wpisałem adres swojej domeny, czyli mojadomena.pl - Po zapisaniu może się "rozkrzaczyć". NIE PANIKUJ! (tak jak ja :)) poprostu strona Admin się zmieniła
    2. W Konfiguracji domeny Przekierowanie ruchu > "Włącz przekierowanie na podkatalog bez separacji serwisu" i w polu wpisać /autoinstalator/wordpress/

    i teraz już spokojnie można zalogować się do http://mojadomena.pl/wp-login.php . Ja tego nie wiedziałem i zacząłem panikować. Do WP nie mogłem się zalogować i przywróciłem do stanu poprzedniego zmieniając adresy w Panelu MySQL. I potem zakładałem, że jednak Adres WordPressa (URL) powinien być tak jak po instalacji czyli serwer1xxxx.home.pl/autoinstalator/wordpress/

    P.S. Taką radę przy okazji znalazłem gdzie indziej a może się przydać przy migracjach - Można skorzystać z plugina Velvet Blues Update URLs do naprawienia linków (aczkolwiek rekomendowany jest back-up :) )
     
    Mariusz lubi to.

Poleć forum znajomym