1. Forum używa plików Cookies. Dowiedz się więcej o celu ich używania i możliwości zmiany ustawień Cookies w przeglądarce. Czytaj więcej...

ROZWIĄZANE Panel administracyjny WP 404 (not found)

Dyskusja w 'Wordpress Hosting SSD' rozpoczęta przez użytkownika kubaa355, 26 Czerwiec 2018.

  1. kubaa355

    kubaa355 Początkujący

    Wiadomości:
    5
    Docenione treści:
    0
  2. casar

    casar Fachowiec

    Wiadomości:
    385
    Docenione treści:
    113
    Pod drugim z Twoich linków pojawia się formularz logowania. Jak wywołam adres strony/wp-admin, to kieruje mnie na ten drugi adres właśnie (przypuszczam, że nie masz ustawionego adresu strony na adres domeny w Wordpressie).

    Kiedy dokładnie pojawia Ci się 404?

    PS. Masz dostęp SSH w ramach swojej usługi? Mógłbym Ci podpowiedzieć jak zaktualizować adres strony czy wyłączyć wtyczkę.
     
  3. kubaa355

    kubaa355 Początkujący

    Wiadomości:
    5
    Docenione treści:
    0
    Poradziłem sobie z tematem i zapomniałem odpisać. Otóż problem tkwił w pamięci podręcznej mojej przeglądarki. Coś wtyczka zcache'owała i wywalało błąd. Natomiast spotkałem się niedawno z problemem podobnej natury. Nie mogę stworzyć nowej strony, ani wpisu na stronie. Wyrzuca właśnie błąd 404 error. Adres witryny w wordpressie mam ustawiony na http://eurorodo.pl . Wszystkie ustawienia wydają się być OK, ale mogę się mylić.

    Czy masz jakiś pomysł gdzie mógłbym znaleźć rozwiązanie?
     
  4. casar

    casar Fachowiec

    Wiadomości:
    385
    Docenione treści:
    113
    404 jest w zapleczu? Czy już pod adresem wpisu/podstrony?
     
  5. kubaa355

    kubaa355 Początkujący

    Wiadomości:
    5
    Docenione treści:
    0
    Pod adresem. Zaplecze działa normalnie, choć nie do końca. Ten problem również chciałbym rozwiązać :) Kiedy jestem zalogowany do panelu administratora i wchodzę na stronę główną to powinienem mieć ten toolbar na górze strony do edycji, wejścia z powrotem do kokpitu itd. A niestety on się nie pokazuje.
     
  6. casar

    casar Fachowiec

    Wiadomości:
    385
    Docenione treści:
    113
    Na Twoim miejscu wyłączyłbym wszystkie dodatkowo zainstalowane wtyczki, potem wyłączył przyjazne adresy i włączył je ponownie, a dopiero potem włączał po kolei wtyczki.

    Z tym nie widocznym toolbarem się nie spotkałem.
     
  7. kubaa355

    kubaa355 Początkujący

    Wiadomości:
    5
    Docenione treści:
    0
    Dobra, zrobiłem tak jak napisałeś. Problem faktycznie tkwił w przyjaznych adresach. Nie ważne czy wtyczki są włączone czy nie innych odnośników niż Prosty nie mogę użyć (wyskakuje 404). Jest jakiś sposób aby to rozwiązać?
     
  8. casar

    casar Fachowiec

    Wiadomości:
    385
    Docenione treści:
    113
    Sprawdź przy włączonych prostych adresach i wyłączonych wtyczkach masz w katslogu ze stroną plik .htaccess z jakimkolwiek wpisem - powinny być takie domyślne Wordpressowe.

    A jak nie wtyczki to moze szablon?

    Aczkolwiek aktualnie na stronie, ktorą wskazałeś nie widzę 404.

    Wysłane z mojego PLUS przy użyciu Tapatalka
     
  9. kubaa355

    kubaa355 Początkujący

    Wiadomości:
    5
    Docenione treści:
    0
    W .htaccess nie było nic. Znalazłem na stronie wordpress.org informacje, że trzeba dodać to do pliku:
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress

    Dodałem i odnośniki działają :)

    Wracając do "znikniętego" panelu admina na stronie głównej. Zauważyłem, że gdy zmienię adres URL witryny na adres URL Wordpressa to panel na stronie głównej się normalnie pojawia. Dedukuję więc, że zmieniając adres URL witryny na ten z domeny i wchodząc na stronę główną będąc zalogowanym wordpress "myśli", że jestem w innej witrynie i mi go nie wyświetla. Jakieś pomysły?
     
  10. casar

    casar Fachowiec

    Wiadomości:
    385
    Docenione treści:
    113
    Taki zapis powinien się sam utworzyć, kiedy włączysz przyjazne linki. Ale dobrze, że działa.

    W drugiej kwestii, doprowadź do efektu i sprawdź co pokazuje przeglądarkowa konsola - PPM na stronie > Zbadaj element > Console
    upload_2018-7-24_22-36-29.png
     
  11. Grzesiek

    Grzesiek BOK home.pl home.pl Administrator forum

    Wiadomości:
    3 342
    Docenione treści:
    315
    @kubaa355 czy problem nadal występuje, czy udało się go rozwiązać?
     

Poleć forum znajomym