1. Forum używa plików Cookies. Dowiedz się więcej o celu ich używania i możliwości zmiany ustawień Cookies w przeglądarce. Czytaj więcej...

prestashop_1.7

Dyskusja w 'Sklep internetowy PrestaShop' rozpoczęta przez użytkownika mario1508, 28 Grudzień 2018.

  1. mario1508

    mario1508 Aktywny user

    Wiadomości:
    79
    Docenione treści:
    0
    Dzień dobry,
    próbuje zainstalować prestashop_1.7
    ale niestety nie udaje się.
    Instalacja wywala błąd podczas instalacji tabel.
    Moje php.ini:
    error_log = /plik_logow.log
    error_reporting = E_ALL & ~E_NOTICE
    log_errors = 1
    display_errors = off
    memory_limit = 512M
    file_uploads = On
    allow_url_fopen = On
    zlib.output_compression = On
    zlib.output_compression_level = 6
    extension = mcrypt.so
    magic_quotes_gpc = Off
    magic_quotes_runtime = Off
    magic_quotes_sybase = Off
    extension = pdo.so
    extension = pdo_mysql.so
    max_execution_time = 120
    upload_max_filesize = 32M
    post_max_size = 32M
    max_input_time = 180

    wyczytałem że pomaga wyłączenie statystyk serwera
    ale nie wiem jak to się robi.
    Dziękuje za każdą pomoc.
     

    Załączone pliki:

  2. casar

    casar Profesjonalista

    Wiadomości:
    469
    Docenione treści:
    122
    Nie ma już od kilku lat statystyk (swoją droga to były statystyki od stat.pl), które mogłyby zakłócać działanie jakichkolwiek skryptów, więc nie ma co wyłączać.

    A jak klikniesz w clicking here to coś się dzieje? U mnie niedawno pomogło.
    Jaka dokładnie wersja Prestashopa?
     
    Last edited by a moderator: 20 Sierpień 2019
  3. mario1508

    mario1508 Aktywny user

    Wiadomości:
    79
    Docenione treści:
    0
    Próbowałem instalacji prestashop_1.7.5.0 i prestashop_1.6.1.23 , obie instalacje zatrzymują się na 12% (create database tables)
    atrybuty plików ustawiłem na 777, nie zmieniałem wielkości liter podczas transferu na serwer
    generalnie wszystko powinno być ok. ale nie jest...
    na moim serwerze jest zainstalowana strona, dlatego tworze folder do którego próbuje zainstalować preste
    tworze bazę danych, to wszystko jest ok.
     
  4. mario1508

    mario1508 Aktywny user

    Wiadomości:
    79
    Docenione treści:
    0
    po kliknięciu clicking here proces instalacji rozpoczyna się od nowa z tym samym skutkiem, zatrzymuje się na 12%

    prestashop_1.6.1.23 - transferuje rozpakowane pliki z plikiem install
    prestashop_1.7.5.0 - transferuje plik zip z plikiem install
     
  5. casar

    casar Profesjonalista

    Wiadomości:
    469
    Docenione treści:
    122
    A możesz jeszcze spróbować na 1.7.4.4?
     
  6. mario1508

    mario1508 Aktywny user

    Wiadomości:
    79
    Docenione treści:
    0
    Spróbowałem z wersją 1.7.4.4 jest dokładnie to samo staje na 12% podczas instalacji tabel.
    wcześniej podczas sprawdzania zgodności wszystkie wersje pokazywały:
    To get the latest internationalization data upgrade the ICU system package and the intl PHP extension.
     
  7. LukaszC

    LukaszC eCommerce Team home.pl

    Wiadomości:
    973
    Docenione treści:
    108
    sprawdź czy nie masz skierowanej domeny/subdomeny na ten katalog z separacją serwisu oraz przy wersji presty 1.7 zalecam korzystać z PHP min. 5.6.
     
    Last edited by a moderator: 20 Sierpień 2019
  8. mario1508

    mario1508 Aktywny user

    Wiadomości:
    79
    Docenione treści:
    0
    Dzień dobry, co do wersji presty
    Wybrałem do instalacji prestashop_1.6.0.5 (wolna edycja waluty)
    na serwerze w public_html mam pliki joomla strony która działa.
    Tworze w public_html nowy katalog "presta" nową bazę danych.
    W nowym katalogu próbuję zainstalować prestę i klops.
     
  9. mario1508

    mario1508 Aktywny user

    Wiadomości:
    79
    Docenione treści:
    0
    Instalacja zawsze staje na 12%
    -Tworzenie tabel bazy danych
    moje php:
    error_log = /plik_logow.log
    error_reporting = E_ALL & ~E_NOTICE
    log_errors = 1
    display_errors = off
    memory_limit = 512M
    file_uploads = On
    allow_url_fopen = On
    zlib.output_compression = On
    zlib.output_compression_level = 6
    extension = mcrypt.so
    magic_quotes_gpc = Off
    magic_quotes_runtime = Off
    magic_quotes_sybase = Off
    extension = pdo.so
    extension = pdo_mysql.so
    max_execution_time = 120
    upload_max_filesize = 32M
    post_max_size = 32M
    max_input_time = 180
    max_input_vars=2000
    short_open_tag = Off
     
  10. LukaszC

    LukaszC eCommerce Team home.pl

    Wiadomości:
    973
    Docenione treści:
    108
    pokaż zrzut ekranu z komunikatu błędu oraz jaką masz wersję PHP ustawioną w konfiguracji hostingu ?
     
    Last edited by a moderator: 20 Sierpień 2019
  11. mario1508

    mario1508 Aktywny user

    Wiadomości:
    79
    Docenione treści:
    0
    PHP w wersji 5.6
    atrybuty plików 777
    próbowałem:
    -prestashop_1.6.1.23
    -prestashop_1.7.5.0
    -prestashop_1.6.0.5
    każda staje na 12% presta.jpg Screenshot_2018-12-30 Asystent instalacji PrestaShop.png
     
  12. casar

    casar Profesjonalista

    Wiadomości:
    469
    Docenione treści:
    122
    Dziwne, u mnie na Starterze 1.7.4.4 zainstalowała się bez przeszkód. Tylko musiałem ponowić instalację przez wybranie klikając tutaj, bo od razu miałem ten błąd, ale u mnie poszło dalej.
     
  13. LukaszC

    LukaszC eCommerce Team home.pl

    Wiadomości:
    973
    Docenione treści:
    108
    w przypadku Presty 1.7 sugeruję sprawdzić wersję PHP 7.1, a w przypadku błędu z dodaniem tabel możesz spróbować wyczyścić bazę danych i wykonać instalację na nowo.
     
    Last edited by a moderator: 20 Sierpień 2019
  14. mario1508

    mario1508 Aktywny user

    Wiadomości:
    79
    Docenione treści:
    0
    Po kilku próbach na razie poddałem się, zrobiłem instalacje na localhost.
    I odkryłem coś bardzo przyjaznego w starszej wersji presty 1.6. Swobodną edycje walut (wybór symbolu waluty, nie pokazywanie liczb dziesiętnych)
    nie muszę nadpisywać kodu. Także zostaje z prestą 1.6 na komputerze i tam ją testuje.
    Dziękuje wszystkim za pomoc.
     
  15. casar

    casar Profesjonalista

    Wiadomości:
    469
    Docenione treści:
    122
    Gdyby komuś się jeszcze coś takiego trafiało na wersji 1.7.x.x, to polecam sprawdzić uprawnienia pliku katalog_ze_sklepem/var/cache/prod/appParameters.php . Nie wiem dlaczego, ale plik ten ma zerowe uprawnienia i instalator przez niego się wywala.
    W momencie kiedy pojawi się komunikat jak na screenie, należy ustawić uprawnienia do odczytu i zapisu (np. 666/rw-rw-rw) na tym pliku i puścić instalator (przez wybranie klikając tutaj).
     
  16. PawelS

    PawelS (nieaktywny) Administrator forum

    Wiadomości:
    10
    Docenione treści:
    7
    Dzięki za podpowiedź. Problemem jest w tym wypadku OPCache, od którego Presta wymaga dość specyficznych ustawień.
    To, co mogę w tym wypadku powiedzieć / zasugerować. Od niedawna mamy w ofercie usługę dedykowaną PrestaShop (https://home.pl/prestashop), w ramach której dostosowaliśmy OPCache do wymagań Presty. Usługa działa w oparciu o Apache (2.4), ma wyższe niż w przypadku hostingu współdzielonego parametry bezpieczeństwa. Dodaliśmy też dla tej uslugi do Instalatora aplikacji Prestę (obecnie wersja 1.7.4, dzisiaj jeszcze aktualizujemy do 1.7.5), dodatkowo wrzucimy także wsparcie dla wersji 1.6 (bo wiemy, że tych wersji jest jeszcze w sieci baaardzo dużo).
     
    casar lubi to.
  17. Grzesiek

    Grzesiek Centrum Pomocy home.pl Administrator forum

    Wiadomości:
    3 564
    Docenione treści:
    325
    Wszystkich zainteresowanych uruchomieniem sklepu internetowego opartego o PrestaShop, zapraszamy do zapoznania się z nową usługą dostępną w portfolio firmy: Prestahosting. Prestahosting to hosting dedykowany do obsługi PrestaShop.
     
  18. yakusa

    yakusa Stały bywalec

    Wiadomości:
    42
    Docenione treści:
    2
    Tego typu problemy zdarzają się w przypadku kiedy mamy do czynienia ze słynnym w Home ustawieniem "separacji" serwisu...
     

Poleć forum znajomym