1. Forum używa plików Cookies. Dowiedz się więcej o celu ich używania i możliwości zmiany ustawień Cookies w przeglądarce. Czytaj więcej...

W TRAKCIE Problem z wysyłaniem maili przez SSL (wordpress)

Dyskusja w 'Hosting i domeny internetowe' rozpoczęta przez użytkownika Emi, 18 Lipiec 2016.

  1. Emi

    Emi Nowy użytkownik

    Wiadomości:
    3
    Docenione treści:
    0
    Witam,
    mam problem z szyfrowaniem wiadomości wysyłanych z wordpress. Przez port 25 maile są wysyłane, a po włączeniu szyfrowania pojawia się błąd 405. Korzystam z pluginu wp-mail-smtp, ale przetestowałam na kilku innych wtyczkach i problem jest ten sam. Załączam screena z błędem wysyłki testowego maila i ustawieniami wtyczki. Proszę o pomoc.

    [​IMG]
     
  2. Grzesiek

    Grzesiek Centrum Pomocy home.pl Administrator forum

    Wiadomości:
    3 555
    Docenione treści:
    325
    Przede wszystkim zmień port na 465 ręcznie (port szyfrowany) i teraz sprawdź działanie. Teraz masz 587 a to jest nieszyfrowany, co zapewne koliduje z konfiguracją SSL.
     
  3. Emi

    Emi Nowy użytkownik

    Wiadomości:
    3
    Docenione treści:
    0
    Próbowałam różnych ustawień, na 465 też nie działa.
     
  4. Grzesiek

    Grzesiek Centrum Pomocy home.pl Administrator forum

    Wiadomości:
    3 555
    Docenione treści:
    325
    Zmień PHP w panelu na niższą wersję niż 5.6 z ciekawości. A ja wystawiam zgłoszenie do techu, może coś podpowiedzią.
     
  5. Mariusz

    Mariusz pomoc.home.pl home.pl Administrator forum

    Wiadomości:
    3 060
    Docenione treści:
    300
    @Emi Pod tym adresem znajdziesz informacje jak zmienić wersję PHP na serwerze: https://pomoc.home.pl/baza-wiedzy/edycja-preferencji-dla-uslugi/

    Spróbuj również w polu "Password" podać adres e-mail do skrzynki sklep@emiou.pl, bo widzę, że pole jest puste. Przyczyna leży gdzieś indziej, bo według komunikatu, skrypt nie może połączyć się z adresem: ssl://emiou.pl:587 (czyli przy użyciu błędnego portu, poprawny port to 465).

    Zobaczymy co napiszą nasi administratorzy (Grzesiek wysłał zapytanie z konsultacją).
     
  6. Grzesiek

    Grzesiek Centrum Pomocy home.pl Administrator forum

    Wiadomości:
    3 555
    Docenione treści:
    325
    @Emi możesz podesłać w PW dane dostępowe do WP, chcemy zajrzeć do środka. Możesz utworzyć osobnego admina jeśli chcesz. Nie wiemy gdzie leży problem, dlatego że połączenie na porcie 465 czy 587 jest prawidłowe, ale mimo to serwer zgodnie z komunikatem zwraca timeout.
     
  7. Emi

    Emi Nowy użytkownik

    Wiadomości:
    3
    Docenione treści:
    0
    Dziękuję za odpowiedzi.
    Po obniżeniu PHP maile są wysyłane przez port 465 i SSL, więc niby wszystko dobrze, ale gmail oznacza jako nieszyfrowane wiadomości które nie są wysłane z użyciem protokołu TLS. Po zaznaczeniu TLS jest timeout.
     
  8. Grzesiek

    Grzesiek Centrum Pomocy home.pl Administrator forum

    Wiadomości:
    3 555
    Docenione treści:
    325
    @Emi, zostaw ustawienia takie jak były i daj nam chwilę. Dostałem wiadomość z danymi, podesłałem je już do zespołu technicznego, rzucimy okiem. Być może faktycznie problem leży po stronie PHP a co za tym idzie wersji WP czy wtyczek, ale postaramy się pomóc i upewnić w tym przekonaniu.
     

Poleć forum znajomym