1. Forum używa plików Cookies. Dowiedz się więcej o celu ich używania i możliwości zmiany ustawień Cookies w przeglądarce. Czytaj więcej...

ROZWIĄZANE Umiejscowienie modułu z językami na górze sklepu

Dyskusja w 'Zmiana wyglądu sklepu i edycja zaawansowana' rozpoczęta przez użytkownika Kamil, 12 Sierpień 2015.

  1. Stau

    Stau Majster

    Wiadomości:
    340
    Docenione treści:
    98
    Tak się rzeczywiście dzieje, gdy klikniemy na "Własny styl CSS", a tam będzie składania "LESS", której użyli twórcy templatki. Aby to ominąć należy kliknąć w prawym górnym rogu "Edytor HTML/CSS" (zielony kwadracik). Następnie wybierz:

    - styles/user.css

    To będzie dokładnie ten sam fragment, ale z tego poziomu uda Ci się zapisać zmiany.
     
  2. TheL

    TheL @Lider VIP Moderator forum

    Wiadomości:
    2 350
    Docenione treści:
    512
    już mu to poprawiłem :D innym sposobem :D
     
    Mariusz lubi to.
  3. iisjah

    iisjah Użytkownik

    Wiadomości:
    59
    Docenione treści:
    5
    Dzień dobry

    chciałam się spytać czy sposób zpoczątku tego wątku z dodaniem języków na górną belkę sklepu w skórce RWD działa nadal? Podmieniłam normalny kod na

    Kod:
     <ul class="links right inline">
      <li>
      <a href="/pl/index" title="polski / Polska" class="pl_PL">
      <img src="/public/flags/pl_PL.png" alt="">
      </a>
      <a href="/en_US/index" title="angielski / Stany Zjednoczone" class="en_US">
      <img src="/public/flags/en_US.png" alt="">
      </a>
      </li>
      {if true == $user_logged}
      <li class="hello">
      {translate key="Hello"} <b>{$user->user->getName()|escape}</b>
      </li>
    Do body_head.tpl ale nie zmienia się nic na sklepie. Czy powinnam mieć wyłączony moduł języki pod banerem lub w jakiś inny sposób go ustawić?

    (sklep kom-bizuteria.pl )
     
  4. Mariusz

    Mariusz BOK home.pl home.pl Administrator forum

    Wiadomości:
    3 051
    Docenione treści:
    300
    @TheL rzucisz okiem w wolnej chwili na tę modyfikację?
     
  5. iisjah

    iisjah Użytkownik

    Wiadomości:
    59
    Docenione treści:
    5
    Mogę w razie czego, na nowo dodać tą modyfikację żeby można było zobaczyć, co dokładnie nie gra? W tym momencie cofnęłam body_head.tpl do poprzedniej, defaultowej wersji.
     
  6. iisjah

    iisjah Użytkownik

    Wiadomości:
    59
    Docenione treści:
    5
    W sumie najlpeiej żeby działał i wyglądał jak w poscie Gosia_Emandes
    Czyli zamiast flag lub napisów samo EN / PL

    Kod mam już znów wklejony na stronę - może to chociaż pozwoli zobaczyć co może być nei tak?
     
  7. Chris_W

    Chris_W Początkujący

    Wiadomości:
    5
    Docenione treści:
    0
    Działa super :)
    A da się zrobić w tym miejscu rozwijane małe menu z flagami do wyboru języka ?
    Po dodaniu 2 flag słabo się prezentuje na telefonie a chcę dodać jeszcze kilka flag
    www.superspokeguard.com
    Na razie musiałem jeszcze flagi usunąć
     
    Ostatnia modyfikacja: 9 Marzec 2017
  8. papux

    papux Fachowiec

    Wiadomości:
    387
    Docenione treści:
    107
    A nie prościej dodać dynamicznego tłumacza google który tłumaczy wszystko z biegu na wszystkie języki świata?
    Ja tak mam zrobione i nie musze wprowadzać edytować czegokolwiek. Klient wybiera język i ma wszystko przetłumaczone z automatu i to całkiem poprawnie włącznie z podstronami opisami i.t.p.
     
    Mariusz lubi to.
  9. Mariusz

    Mariusz BOK home.pl home.pl Administrator forum

    Wiadomości:
    3 051
    Docenione treści:
    300
    Widzę w Twoim sklepie, że flagi zostały dodane w górnej części sklepu. Mogę tylko doradzić, aby zmniejszyć ten padding z lewej i prawej strony. Wydaje mi się, że odstępy pomiędzy flagami są zbyt duże.
     
  10. Olabela

    Olabela Początkujący

    Wiadomości:
    8
    Docenione treści:
    0
    Witam, wpisałam kod o którym mowa i u mnie nic się nie wyświetla...
     
  11. LukaszC

    LukaszC eCommerce Team home.pl Moderator forum

    Wiadomości:
    752
    Docenione treści:
    86
    @Olabela podaj adres sklepu będziemy mogli wówczas pomóc :)
     
  12. Olabela

    Olabela Początkujący

    Wiadomości:
    8
    Docenione treści:
    0
  13. LukaszC

    LukaszC eCommerce Team home.pl Moderator forum

    Wiadomości:
    752
    Docenione treści:
    86
    @Olabela masz obecnie uruchomiony domyślny wygląd RWD z wymuszeniem adresu sklepu. Sugeruję uruchomić kopię skórki jako aktywną lub zobaczyć podgląd przy wyłączeniu wymuszenia w konfiguracja->ustawienia podstawowe->informacje o sklepie
     
  14. Olabela

    Olabela Początkujący

    Wiadomości:
    8
    Docenione treści:
    0
    Nie działa...
     
  15. LukaszC

    LukaszC eCommerce Team home.pl Moderator forum

    Wiadomości:
    752
    Docenione treści:
    86
    @Olabela uruchom Twoją modyfikację jako wygląd aktywny, ponieważ teraz nie ma nic dodanego do pliku tpl. Obstawiam, iż sprawdzasz podgląd kopii z włączonym wymuszeniem adresu, a to powoduje wczytanie się aktywnego stylu graficznego.
     
  16. Olabela

    Olabela Początkujący

    Wiadomości:
    8
    Docenione treści:
    0
    Dziękuję, wstawiłam poniższy kod, zadziałały języki polski i angielski, niestety nie niemiecki (wpisałam analogicznie do angielskiego, nie wiem czy tak można).
    Pojawiły się flagi, ale z dość dużymi odstępami, co rozumiem, że mogę to zmienić w CSS? Przepraszam ale jestem zielona.
    Jeśli chodzi o flagi, najlepiej podobałaby mi się wersja bez nich, czyli w postaci zapisu PL I EN I DE
    Jak coś takiego uzyskać?
    Niestety po zmianie języka dalej nie ma tłumaczenia MENU, choć dziś rano na chwilę to tłumaczenie miałam, az zdobiłam prt sc niestety pojawiło się raz. Nie wiem czy to jest na pewno sprawa auktualizacji... Czekam już na to od lipca i tracę klientów.

    Dziękuję za pomoc
    pozdrawiam,
    Ola

    <li>
    <a href="/pl/index" title="polski / Polska" class="pl_PL">
    <img src="/public/flags/pl_PL.png" alt="">
    </a>
    <a href="/de_DE/index" title="niemiecki / Niemcy" class="pl_DE">
    <img src="/public/flags/de_DE.png" alt="">
    </a>
    <a href="/en_US/index" title="angielski / Stany Zjednoczone" class="en_US">
    <img src="/public/flags/en_US.png" alt="">
    </a>
    </li>
     
  17. Olabela

    Olabela Początkujący

    Wiadomości:
    8
    Docenione treści:
    0

    Wyczytałam wyżej, że można wpisać zamiast kodu obrazka po prostu PL EN etc i tak zrobiłam, ale zniknał mi sklep... Więc przywróciłam poprzednią wersję. Jaki kod powinnam wpisać?
    dziękuję
     

Poleć forum znajomym