1. Forum używa plików Cookies. Dowiedz się więcej o celu ich używania i możliwości zmiany ustawień Cookies w przeglądarce. Czytaj więcej...

W TRAKCIE Wordpress problem z SSL

Dyskusja w 'Wordpress Hosting SSD' rozpoczęta przez użytkownika Sp00n, 20 Październik 2017.

  1. Sp00n

    Sp00n Początkujący

    Wiadomości:
    6
    Docenione treści:
    0
    Witam, wczoraj ustawiłem sobie SSL z cloudfare. Wszystko działało poprawnie, jednak dzisiaj strona sie nie wyświetla. Jesli dobrze mysle jest to spowodowane zmiana serwera DNS na mojej domenie, ktora musiałem zmienić(jednak nie jestem pewien). Prosiłbym o pomoc w rozwiązaniu mojego problemu.

    Pozdrawiam.
     
  2. Mariusz

    Mariusz BOK home.pl home.pl Administrator forum

    Wiadomości:
    3 034
    Docenione treści:
    300
    Cloudflare pobiera od nas dane (pobierają np. stronę WWW) i następnie ją cache'ują. Na tej podstawie funkcjonuje Cloudflare. Sugeruję skontaktować się z nimi w celu sprawdzenia co "nie zadziałało". Gdy otrzymasz niezrozumiałe dla Ciebie informacje zwrotne, daj nam znać tutaj na forum.
     
  3. Sp00n

    Sp00n Początkujący

    Wiadomości:
    6
    Docenione treści:
    0
    Na razie, nie dostałem odpowiedzi. Tym samym chciałem powrócić do starych ustawień sprzed dodaniem SSL, zmieniłem z powrotem serwery DNS na te z home.pl, wyłączyłem również wszystko na cloudflare. Jednak wchodząc na stronę występuje komunikat
    "Error establishing a database connection"

    Co muszę zrobić w tej sytuacji ?
     
  4. Grzesiek

    Grzesiek BOK home.pl home.pl Administrator forum

    Wiadomości:
    3 252
    Docenione treści:
    313
    Zgodnie z informacjami z Google, błąd wskazuje na problem z połączeniem z bazą danych.

    Podstawowe pytanie brzmi: jakie zmiany wykonywałeś w samym CMS, na serwerze lub w panelu administracyjnym. Nie ma możliwości aby od tak przestało to działać, chyba, że dokonałeś jakiś zmian. Np. zmianę hasła do bazy danych w panelu.
     
  5. Mariusz

    Mariusz BOK home.pl home.pl Administrator forum

    Wiadomości:
    3 034
    Docenione treści:
    300
    WordPress nie może połączyć się z bazą danych. Sprawdź poprawność danych takich jak nazwa bazy danych, uzytkownik bazy danych oraz hasło do bazy danych w pliku wp-config.php. Warto też sprawdzić nazwę hosta serwera MySQL (powinno być localhost). Jeśli baza danych znajduje się na serwerze w home.pl, to nazwa użytkownika bazy danych oraz nazwa bazy danych są takie same.
    Kod:
    /** Nazwa bazy danych, której używać ma WordPress */
    define('DB_NAME', 'nazwa-bazy-danych');
    /** Nazwa użytkownika bazy danych MySQL */
    define('DB_USER', 'nazwa-uzytkownika');
    /** Hasło użytkownika bazy danych MySQL */
    define('DB_PASSWORD', 'haslo-do-bazy');
    /** Nazwa hosta serwera MySQL */
    define('DB_HOST', 'localhost');
     
  6. Sp00n

    Sp00n Początkujący

    Wiadomości:
    6
    Docenione treści:
    0
    Miał Pan racje, hasło do bazy danych było niepoprawne. Ustawiłem już certyfikat, jednak przez przypadek wyłączyłem wtyczkę cloudflare flexible ssl po czym wywaliło mnie z serwera i nie mogłem się zalogować, po prostu wpisując dobre dane nic się nie działo. Wyświetlał się też komunikat w przeglądarce odnośnie niezabezpieczonych treści. Myślałem, ze uszkodzeniu uległ plik wp-login, jednak wszystko było w porządku. Ostatecznie próbując przejść do panelu logowania wyświetla się komunikat [​IMG]. http://prntscr.com/h1f0g5 Gdzie mogę szukać błędu ?
     
  7. Grzesiek

    Grzesiek BOK home.pl home.pl Administrator forum

    Wiadomości:
    3 252
    Docenione treści:
    313
  8. Sp00n

    Sp00n Początkujący

    Wiadomości:
    6
    Docenione treści:
    0
    Próbowałem dodać htaccess'a do katalogu głównego, public_htm oraz samego katalogu ze stroną. Do public_html wrzuciłem kod
    Kod:
    RewriteEngine On
    RewriteCond %{HTTP_HOST} ^(www\.)?e-hacked\.eu$ [NC]
    RewriteCond %{REQUEST_FILENAME} !/autoinstalator/wordpressplus1/
    RewriteRule ^(.*)$ /autoinstalator/wordpressplus1/$1 [L]
    a do folderu głównego /public_html/autoinstalator/wordpressplus1. Jednak błąd był ten sam. Następnie wpadłem na pomysł, aby do folderu public html wrzucić accessa o treści
    Kod:
    RewriteEngine on
    RewriteRule ^(.*)$ /autoinstalator/wordpressplus1/$1 [L]
    Zmieniło to jedynie błąd na : http://prntscr.com/h2aunk

    Jak mogę dodatkowo zmodyfikować kod, aby owe przekierowanie działało poprawnie ?
     
  9. Grzesiek

    Grzesiek BOK home.pl home.pl Administrator forum

    Wiadomości:
    3 252
    Docenione treści:
    313
    @Sp00n Sprawdź teraz :) Zakładam, że jakiś "biały znak" musiał się wkraść do rewrita. Jest ok?
    pobrane.png
     
  10. Sp00n

    Sp00n Początkujący

    Wiadomości:
    6
    Docenione treści:
    0
    Tak, strona działa i wyświetla się jednak bez certyfikatu SSL oraz nie da się zalogować do wordpressa. Po przejsciu do wp-admin wyświetla się komunikat : http://prntscr.com/h2qfhu. Po kliknięciu "wczytaj niebezpieczny skrypt" przechodzi do normalnego panelu logowania jednak nie zmienia to faktu braku możliwości zalogowania się : http://prntscr.com/h2qgw7.
     
  11. Grzesiek

    Grzesiek BOK home.pl home.pl Administrator forum

    Wiadomości:
    3 252
    Docenione treści:
    313
    1. Brak SSL - kup, opłać, zamów dla domeny, potwierdź i po wydaniu zainstaluj na serwerze
    2. Zakładam że z tego powodu sypie się okno logowania, bo rozumiem, że po stronie WP już jest ustawione wszystko na e-hacked.eu?
     
  12. Sp00n

    Sp00n Początkujący

    Wiadomości:
    6
    Docenione treści:
    0
    1. Korzystam z cloudflare, także mam już SSL
    2. Tak

    Zastanawiam się jedynie jak to można sprzęgnąć, aby wszystko działało.
     

Poleć forum znajomym